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New features introduced with release X4

General functions and Supervisor Environment

O 0O N O N

* New management of the manual and online-help in html format that replaces the
previous one improving the support on the latest operating systems. The manual can be
accessed both from the menu with the command 'Help > Manual > User manual', by
pressing the [ F1 ] button and in a contextual way through the dedicated button within the

program dialogues.
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Improved language change management, 'Utility > Change language X

Technical Menu > Change Language': review of the ; | &5
dialog, double click to confirm the selected language Netanes

Italiano =
and automatic restart of the program at language Rolskl, -

Portugués
change. B

Swedish

Deutzch

Added mouse wheel management in the drw Gdir file

. . . . . Mfarming: b lete thi tioh th ill
opening window 'File > Drawings list'. ERa G e
. ) Ok X Cancel

Holding down the [ Ctrl ] key while turning the mouse

wheel will perform a VERTICAL PAN of the panel (CAD

and CAM environments).

Holding down the [ Shift ] key while turning the mouse wheel will perform a
HORIZONTAL PAN of the panel (CAD and CAM environments).

Added fine zoom mode: holding down the [ Cirl ] and [ Shift ] keys while turning the
mouse wheel will perform a precision zoom with lower magnification/reduction (CAD
and CAM environments).

Label management: QR-CODE and DATA MATRIX fields introduced.

Dim X: 370.00 Dim X: 370.00

Dim Y: 170.00 Dim Y: 170.00

Dim Z: 8.00 Dim Z: 8.00

ID35014 ID35014

Nome disegno Nome disegno
ROVER_S-FT_1224 ROVER_S-FT_1224

DEF DEF

With the 'Preferences > General' command you can now set the size of the start/end
path symbols displayed during 'Cut and Join' mode in CAD or with 'Display > Routing
ends' active.

Introduced new symbol to indicate CLOSED paths.
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Layer management window ('Layer > Edit): after deleting a layer the cursor automatically
positions itself on the next one after the one deleted, speeding up the elimination of a

series of unused layers;

Improved 'destination folder' selection window. When the dialog opens, the path to the

last selected folder will be automatically displayed.

CAD Environment

Added the print flag display in the layer selection window and improved list navigation

via keyboard;

Added "Mirror in X" and "Mirror in Y" command for tilted machining (3D).

Enhanced the command 'Path > Routings reduction'.

Routings global direction:

Replaced the command 'Set > Global direction' with the new command 'Set > Routing

direction': you can now distinguish between the direction to be set for open routes
(right/left) and the direction for closed routes (clockwise/counter-clockwise).

It is possible also choose which paths to apply this setting to:
- all paths in the drawing,

all paths on the current face,

all paths on the current layer,

- all paths currently selected (using the apposite button).

ROUTINGS GLOBAL DIRECTION X
Direction
Open paths [3] Clozed paths [1]
() Left f (O Clockwise
(®) Right __-\ (@) C.clockwise
Ll RS | "
Apply ta
| . ! (®) Al routingz in the drawing (4] @ Selected routings (0] D
@ (O Routings on the curent face (4] @ () Routings on the current layer (4]
:: Help s Ok X/ Cancel

The panel sizing command is now available among the various toolbar customization
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commands.

CAM Environment and TOOLING

Improoved the tooling dialog;

Infroduced the possibility to move the panel (PAN) by holding down the mouse wheel, in

the same way as in the CAD environment.

Revised appearance and colours of the tool
selection list. Increased the dialog height to
display multiple tools simultaneously.

The tool selection list supports scrolling with the
mouse wheel and double-click and keyboard for
selection;

Sequence environment: added checkboxes in the
machining sequence tree to be used as a
reference for moving elements of the sequence.
Improved manual sequence management
*Machining > Manual Sequence > Set':

the sequence modification is not inferrupted by
clicking on the panel and it is possible to

TOOL SELECTION

No tool

Entity not machined

Drilling unit 1]

# T2091 - LAMA D120

Thickness 4.00
Tool change posit. 1

1- FRESA D11

Diameter/ Useful length 11.00 / 50.00
Tool change posit. 2

2 - FRESA D11

Diameter/ Useful length 12.00 / 50.00
Tool change posit. 3

3 - FRESA D13

Diameter/ Useful length 13.00 / 50.00
Tool change posit. 4

4 - FRESA D14

Diameter/ Useful length 14.00 / 90.00

v

| Help | | Ok | |Cancel|

&

resume the numbering from a specific point by clicking on the entity while holding down

the [ Cirl ] key.

The number of the last clicked entity also takes a different colouring.
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* Sequence environment: enhanced sequence recording functionality 'Sequence > Record'.
As entities are clicked in sequence to determine their order, they remain in red, making it
easier to identify those for which the order has not yet been defined.

* Reviewed view options dialog, 'Options > View'.

* Reviewed part-program display dialog.
The dialog is resizable and by holding down the [ Cirl | key while rotating the mouse
wheel, you can enlarge or reduce the font size of the displayed program. In addition,
using the dedicated buttons, you can open the folder containing the program (1), print it
(2) and customize the program display with different settings (3).

B d\ats\p2part\ ATS.PGM X

In the various settings you can:

- change the colors of the text and background according to our preferences or choose
from some default themes;

- enable/disable the display of line numbers; PROGRAN-UEW OPTIONS x
_ modlfy -I-he fOﬂT fype . [+ Remember window position and dimensions
’

aye . . how line numbers
- remember the position and size of the window. .

Font Courier New 11 Aa

Colors
Default themes

(®) Dark 1 Oipark 2

Background color - Oight 1 (CLight 2

Text color

& Ol X Cancel
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Nesting Optional Module

* Improved toolba

r management.

* Improved the graphic printing of nesting layouts: added the management of rectangular
pieces rotated by any angle, polygonal pieces (i.e. whose cutting path is made up of
straight lines) and circular-shaped pieces.

* Credtion of additional layouts for entities on the lower face of the panel:

it is now possible to add drawings containing machining on the lower face of the panel
to the NESTING list. In this case the Nesting Module will automatically generate
2 layouts: the first containing only the machining of the lower face and a second layout
for the machining on the upper face. The machine operator will first process the layout
with the lower face machining, then complete the layout by filting the panel and
machining the upper face.

[ Sart cutting parts seque

Free form
[Ikeep the d

%  [Keepthep

Keep leadindo

Lead-n/Lead-out

Hole b anagement
[ Hole filling
Fririty hole filling

Machinings on the lawer Face

Llze the machiningz on the lower face

Iirrar the regult wertically

<) Rlestore

NESTING OPTIONS st
Cutting toaol data
—, Force tool
2& Selectsdtoo an
' ToolsAPM 18,000 RPM
Starting speed 4.000 mmdmin
@ working zpeed 4,000 mm/min
10,00
Cutting paths
Add cuttin P3| (ESTING OPTIONS: Advanced
Toal tolerance e o
(1 Usze tool def S
(=T ; ; Through cut | Configurs
Mesting sequence Automat
F @ Use projec! g seq utamatic bl £
2 Waste Configure
D: Cutting directio Check thickness U i
: Chegisnaten 0 [ Use the number of shests
Cutting mode
N | Cutting paths Optimizing the parts on different sheets
armal o
Cideietartinglpor D Criterion to select tie lapout
Paths sequence (®) Layout with absolute minimum waste
Toal corection D

() First aptimized lavout with minimum waste

Suggest the size of the sheets
[ Dimenzion ¥
[ Dimension v

100.00

Y, Ok X/ Cancel
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Introduced new low speed machining strategy for 'small' parts. This mode is now
available among the [ Cutting Modes | options accessible via the command 'Process >

Processing Options' as an alternative to onion-skin and tabs.

OPZIONI NESTING

x
Dati utensile di taglio
—= Farza utensile =
VELOCITA NORMALI
| Utensi i 2 (/]
\ 2 tensile selezionato i
Fiotazioni dell'utensile 18,000 FPht Abilita golo per pezzi piccoli % Conrfigura ...
“elocits iniziale di ingreszo (4,000 M mir ’ N
@ Welocits normali
“elocits di avanzamento 4,000 mm#min
12.00 Welocita di ingresso 4,000.00 mm/min
Velocita di taglio 4.000.00 A
Percorsi di taglio
L X Velocit ridotte
Aggiungi percorso di taglio
A o
Tolleranza utensile o Welocita di ingresso 50.00
(O Usa profondita 18.25 mm Welocita di taglio %
F (®) Lsa spogenza 1.00 mm
5,__ Direzione taglio Oraria b x Annulla
todalits di taglio
“elocits ridotta e ‘fb’ Configura ...
e 2 PEZZO PICCOLO
E—— Criterio di valutazione
L] Ordina sequenza taglo pezei Sl @)} Pezzo con entrambe |2 dimensioni inferior a ~
Perimeto
Forma libera x
[] Mantieni le profondita per forme libere m
‘Q [] Mantieni le priorita per e forme libere (O Pezzo con area inferiore a:
I antieni ingressouscita Messuno ~ 0.00
2 Avanzati ) Ok % Annula ) Ok X/ Annula

File creation for automatic label printers (for supported configurations)

. The generation of

all the files required by the automatic label printers (labels, lists, previews) takes place
automatically during the generation of the machine program of the nesting scheme.

PROGRAM GEMERATION > |
LABEL PRINTING OPTIONS *
Parameters
File names Label hames
Program name prefis
Uze template
|se template AEMN2tS ampled | = F
Falder for labels
Folder where programs are generated
Llze the part-program Folder
|EAATS \PARTMER-ASPAN'p2part | 1=
Add a subfolder with order name CAATSPARTNER -85 PANADZpart i SN atS ampledt,
[] Generate data for automatic label printing Options Add a subfolder with part-program name
Ovenwrite existing part-programs
[ Decreases the amount of sheets in stock. []Alsa generate the label otated by 180
[ &z generate the nesting layout images
] Do ot show this window again
: Ok 5 Cancel
g Generates 5 Cancel
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Macro

New macro command ~GetToolld

~GetToolld(Typelay, IdxLav) function can now be called from macro/processor to obtain
the ToolNumber (or ToolCode) of the tool assigned (also automatically) to the machining
specified by the parameters provided.

Note: The existing ~GetTool command only returns this information if the machining has
been manually assigned.

New macro command ~FolderSelect

displays folder selection dialogs in the style of Win7/8/10.

~LET [ret] = ~FolderSelect(<dlgtitle>, "folder name")

Unlike the ~FolderSel function which always shows the complete folder tree,
~FolderSelect opens the dialog at the location specified in "folder name".

New macro command ~SplitWideArc

Breaks the provided arc into 2 (or 3) equal parts if the angle it underlies is greater than
180° (or=360)

~LET [ref] = ~SplitWideArc(<idx>)

Revised Macro manual 'APL Language Ref, which can be found in the program
installation folder inside the 'PDF' folder.

Other improvements

Strategy Layer Import: it is now possible to define among the processor parameters,
within the import profile, a series of layers to exclude from the import. All entities
belonging to these layers will not be imported.

Management of CUTTER tools;
PGMX format support for SCM machines with TWIN HEAD machine management.

New distribution format: the program is now distributed not only as a digital download or
CD-ROM, but also on a USB stick with new packaging and documentation.

Vacuum cups environment: it is now possible to activate the 'fransparent’ mode of the
panel in order to visualize the machinings present on the lateral and lower faces.

In addition to the usual visual positioning using the mouse, the possibility of manually
specifying the height of the vacuum cups through a dedicated window has been added.
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